CodeIgniter Support in NetBeans


Lately I’ve been doing some development using CodeIgniter (a very popular PHP framework), and I was wondering, how to get CodeIgniter support in NetBeans. So anyway, I’ve found a NetBeans plugin under the Project Kenai

This plugin will allow you to create CodeIgniter projects right from NetBeans’ Create New PHP Project Wizard, also it’ll provide full auto-completion while you’re coding.

In this post I’ll explain how to get this plugin to work. First you should make sure that you have at least NetBeans 7.0 installed on your machine. NetBeans 7.1 and 7.2 are also supported. Also go ahead and download the latest version of CodeIgniter.

1. From NetBeans go to Tools menu, then choose Plugins, and then select the Settings tab.

2. Click on the Add button on the window appeared from the last step.

3. Type any name you find appropriate, and for the URL paste one of these links depending on your NetBeans version, and click Ok.

4. Go to the Available Plugins tab, and search for CodeIgniter, two plugins should appear (Framework and Framework Repository), check both of them and click Install.

5. Go to Tools menu, and choose Settings. Then go to PHP tab. You should find a new tab for CodeIgniter, switch to it.

6. Under Base Files click Add type an appropriate name in the name field, and browse to the CodeIgniter’s zip file you downloaded earlier. Finally hit the Ok button.

7. Now restart NetBeans, and once it’s restarted try to create a new PHP project via the File menu.

8. Go through the few steps of creating a new project, and at the final step underPHP Frameworks you should find CodeIgniter there, check it and hit Finish.

Create New PHP Project Wizard

There you have it! You can now start coding with CodeIgniter like a ninja!

[Ref: http://alielwafdy.wordpress.com/2012/07/28/codeigniter-support-in-netbeans/]
Advertisements

8 thoughts on “CodeIgniter Support in NetBeans

  1. Constantin says:

    Hi, Muhammad.
    I followed all steps and couldn’t see the 4th step in creating a new project.
    I’m working on a project built on CI 2.1.0, so the zip I added in Settings -> PHP -> Codeigniter is “CodeIgniter V 2.0.1″, which I”ve downloaded from here: http://codeigniter.com/downloads/.
    Is this what you mean by “download the latest vresion of Codeigniter”?
    Thank you.

    Like

Ask J

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s